ANNOUNCE: GHC version 6.12.1

Daniel Fischer at
Mon Dec 14 16:49:51 EST 2009

Oh great, that's not what I expected:

$ cabal install cabal-install
cabal: This version of the cabal program is too old to work with ghc-6.12+.
You will need to install the 'cabal-install' package version 0.8 or higher.
If you still have an older ghc installed (eg 6.10.4), run:
$ cabal install -w ghc-6.10.4 'cabal-install >= 0.8'
$ cabal install -w ghc-6.10.3 'cabal-install >= 0.8'
Resolving dependencies...
cabal: There is no available version of cabal-install that satisfies >=0.8

Oops, nothing higher than 0.6.4 on Hackage, even is only 
version 0.7.5. 
That seems to work, though, but I needed to manually install network, mtl and parsec 
before ran.

More information about the Glasgow-haskell-users mailing list