Build error in users guide in HEAD of today

Christiaan Baaij christiaan.baaij at
Fri Aug 21 09:07:06 EDT 2009


I had the same problem. I'm using the dblatex (version 0.2.10) from  
macports (on OS X 10.5.7), which isn't the latest version of dblatex.  
Also I'm using the MacTex 2008 Tex distribution, but I have no idea  
what the particular versions of the url or hyperref package are.  
Anyhow, I solved this particular problem by changing the style sheets  
in my dblatex install. I found them under: /usr/local/share/dblatex/xsl

In the 'url.xsl' stylesheet I replaced the nolinkurl template with the  

<xsl:template name="nolinkurl">
   <xsl:param name="url" select="@url"/>
   <xsl:call-template name="scape-encode">
     <xsl:with-param name="string">
       <xsl:call-template name="scape-replace">
         <xsl:with-param name="string" select="$url"/>
         <xsl:with-param name="from" select="'\'"/>
         <xsl:with-param name="to" select="'\\'"/>

So yeah, basically it is a mechanization of your manual solution.  
Maybe you should bring this up with the dblatex folks? They have this  
bug report on it [1], but the appearently they could not reproduce it  
with 0.2.11. I can't verify if it is indeed solved with 0.2.11 and  
onwards, and have no intention of doing so as I'm satisfied with my  
current solution. Hope this helps you for now.




More information about the Glasgow-haskell-users mailing list