ANNOUNCE: GHC 6.10.1 beta

Judah Jacobson judah.jacobson at
Tue Sep 23 13:25:52 EDT 2008

Christian, I'm not sure about the other issues you mentioned but can
probably help with the following.

On Tue, Sep 23, 2008 at 6:38 AM, Christian Maeder
<Christian.Maeder at> wrote:
> But finally installation succeeded (editline is missing and the arrow
> keys don't work).

This means that the editline package could not be built for some
reason.  Is this on your OS X machine?  If so, it's strange because
libedit should be installed on OS X by default; what OS version are
you running?  If you separately download and build the editline
package from hackage, what errors do you get?

> Why are there 2 base packages?

base-3.0.3 is a compatibility package which provides the same API as
in ghc-6.8.*.  The base-4 package has the new API (for example,
extensible exceptions).


More information about the Glasgow-haskell-users mailing list