more issues

James Swaine james.swaine at
Fri Nov 14 12:46:08 EST 2008

that didn't fix the problem - i still get the same error message.  the
configure script help should be updated though to show that these two
options are available.


On Fri, Nov 14, 2008 at 11:28 AM, Judah Jacobson
<judah.jacobson at>wrote:

> 2008/11/13 James Swaine <james.swaine at>:
> > We've had unbelievable problems getting past this ridiculous 'unable to
> load
> > object file or shared library' error when attempting to
> build
> > the 6.10.1 source tree.  We initially just built editline in a user
> > directory and attempted to manipulate environment variables to help the
> > linker (e.g. setting LIBRARY_PATH, LD_LIBRARY_PATH, and CPATH) - but this
> > did no good.
> >
> I'm not sure whether this will fix your problem, but if you want to
> build ghc using a libedit in a nonstandard location, there's an easier
> solution than setting all of those environmental variables: just
> configure ghc with (for example)
> ./configure --with-editline-includes=/opt/local/include
> --with-editline-libraries=/opt/local/lib
> -Judah
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Glasgow-haskell-users mailing list