Notes on building 6.10.1

Ian Lynagh igloo at
Wed Nov 12 17:52:41 EST 2008

On Wed, Nov 12, 2008 at 12:42:00PM -0500, Gregory Wright wrote:
> The hpc library is the only one that requires the external hsc2hs.  Is  
> this new dependency
> intentional, or is this a build system bug?

I don't think that the build dep is necessary, but with the current
filesystem layout it's a pain to avoid. We would need to, with the
bootstrapping compiler:

Build libraries/{filepath,Cabal,cabal-bin}
Build utils/hsc2hs
Build libraries/hpc
Build compiler (stage 1)

We plan to rewrite the build system for 6.12 anyway, so I think we
should take care of this then. It probably makes sense to merge (some
of?) "utils" and "libraries" into "packages".

As far as 6.10 is concerned, we install hsc2hs with ghc by default, so I
think it is reasonable to depend on it.


More information about the Glasgow-haskell-users mailing list