ghc 6.8.3 build error with __DISCARD__ linking problem, please help!

Yu Di diyu60607 at
Sat Jul 26 13:47:03 EDT 2008

Thanks! I installed 6.8.2 binary and that successfully compiled 6.8.3 source with gcc 4.1.1. (I am still not sure why a direct 6.8.3. binary installation did not work for me, but now I think everything is good). Thanks very much again!

Di, Yu

----- Original Message ----
From: Simon Marlow <marlowsd at>
To: Yu Di <diyu60607 at>
Cc: glasgow-haskell-users at
Sent: Friday, July 25, 2008 3:52:01 AM
Subject: Re: ghc 6.8.3 build error with __DISCARD__ linking problem, please help!

Yu Di wrote:
> Hi, I am trying to build ghc 6.8.3 from source release, my currently 
> installed version is ghc 6.4.2 (x86 linux binary release version), and I 
> got:
> /usr/local/ghc/bin/ghc -o ghc-pkg.bin -H16m -O -cpp -Wall 
> -fno-warn-name-shadowing -fno-warn-unused-matches -DUSING_COMPAT 
> -i../../compat -ignore-package Cabal  -Rghc-timing  -package unix    
> -L../../compat -lghccompat   Main.o Version.o CRT_noglob.o
> Main.o: In function `__stginit_ZCMain':
> ghc13533.hc:(.text+0x4): undefined reference to `__DISCARD__'
> ghc13533.hc:(.text+0x9): undefined reference to `__DISCARD__'
> Main.o: In function `__stginit_Main':
> ghc13533.hc:(.text+0x18): undefined reference to `__DISCARD__'
> ghc13533.hc:(.text+0x1d): undefined reference to `__DISCARD__'
> Main.o: In function `__stginit_Main_':
> ghc13533.hc:(.text+0x2c): undefined reference to `__DISCARD__'
> Main.o:ghc13533.hc:(.text+0x3d): more undefined references to 
> `__DISCARD__' follow
> collect2: ld returned 1 exit status
> <<ghc: 13726704 bytes, 3 GCs, 105428/105428 avg/max bytes residency (1 
> samples), 15M in use, 0.00 INIT (0.00 elapsed), 0.01 MUT (1.98 elapsed), 
> 0.01 GC (0.03 elapsed) :ghc>>
> Do you know how I can fix this problem? My ghc and gcc versions are:
> The Glorious Glasgow Haskell Compilation System, version 6.4.2
> gcc (GCC) 4.1.1 20060724 (prerelease) (4.1.1-4pclos2007)
> (I also tried ghc 6.2.0 and gcc 3.3.6, but all combinations resulted in 
> the same error message)

The error is coming from your installed 6.4.2, and I strongly suspect that 
it is incompatible with the gcc version you have installed.  You could try 
downgrading gcc, but your best bet is to just install a recent GHC binary 


-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Glasgow-haskell-users mailing list