GHC on Solaris Nevada

Christian Maeder Christian.Maeder at
Fri Jan 25 03:48:49 EST 2008

Felix Martini wrote:
> Hello all,
> I am trying to get a working GHC on Solaris Nevada (Solaris 11). I've
> tried the binary versions for Solaris 10 made by Christian Maeder. I
> couldn't get GHC 6.8.2 to install properly and GHC 6.6 does not work
> (it crashes the moment it needs to link to a library). After that i

What are the exact error messages? Do you have all required libraries
(see below)?

> tried to make an unregistered bootstrap of GHC 6.6 using Linux as the
> host OS. The bootstrapping failed on Solaris when making genapply or
> cabal-setup. The linker reports symbol referencing errors. Has someone
> already successfully build GHC on Solaris 11?

bootstrapping from C seems to be pretty hopeless.

Maybe my new binary release is easier to install:

see also


-bash-3.1$ ldd lib/ghc-6.8.2/ghc-6.8.2 =>    /lib/ =>      /usr/local/lib/ =>       /usr/local/lib/ =>    /lib/ =>     /lib/ =>   /usr/local/lib/ =>       /lib/ =>     /lib/ =>   /lib/ =>   /lib/ =>         /usr/local/lib/ =>        /lib/ =>   /lib/ =>         /usr/local/lib/ =>    /lib/ =>   /lib/ =>  /lib/ =>         /lib/ =>   /lib/

More information about the Glasgow-haskell-users mailing list