Integrating editline with ghc

Christian Maeder Christian.Maeder at
Mon Jan 21 05:40:07 EST 2008

Judah Jacobson wrote:
> I think it will be much simpler if we keep the readline and editline
> packages as they are now, and possibly add a third readline-compat
> package which can use either one as a dependency.  Then any project
> (including GHC) can choose which of those packages to use, based on
> API requirements and/or license issues.

Could then editline go already into ghc-6.8.3, because interfaces don't

Re-iterating, I would like to see your package readline-compat and hope
 it will be sufficient for the packages Shellac and Shellac-readline.
(Even better if the current package readline is renamed to old-readline
and readline-compat to readline.)

I wonder how many hackage packages have readline as build-depends (and
how many of them would be content with readline-compat).

Which version of editline to you require?

Our newest version installed (under Solaris) is: editline.h,v 1.5

Which include files are used on Macs?

Cheers Christian

More information about the Glasgow-haskell-users mailing list