hsc2hs problem

Creighton Hogg wchogg at gmail.com
Fri Dec 5 11:05:39 EST 2008

On Fri, Dec 5, 2008 at 9:49 AM, Duncan Coutts
<duncan.coutts at worc.ox.ac.uk> wrote:
> On Thu, 2008-12-04 at 13:06 -0600, Creighton Hogg wrote:
>> Hello,
>> Since hsc2hs is distributed with GHC, I thought this might be a decent
>> place to ask.  I tried to run hsc2hs on a file that I know worked with
>> my 6.8.3 installation, but now I'm getting the error
>> /usr/local/lib/ghc-6.10.1/hsc2hs-0.67/template-hsc.h:4:19: error:
>> HsFFI.h: No such file or directory
> Unfortunately the hsc2hs instance is specific to one ghc version. You've
> presumably got ghc-6.8.3 and ghc-6.10.1 installed. You're building stuff
> using ghc-6.8.3 but the hsc2hs from ghc-6.10.1 and so hsc2hs is getting
> passed the wrong include paths. If you use the hsc2hs from the ghc-6.8.3
> installation then it should work.
> We should look into making it more independent of the ghc version.

Funny you'd mention this!  I was worried that this was the problem, so
I cleaned out all my ghc instances & then reinstalled ghc 6.10.1 from
the binaries.  I still had the same problem after that.  Perhaps
something was still lingering?  I'm not sure what, though.


More information about the Glasgow-haskell-users mailing list