ANNOUNCE: GHC 6.8.1 Release Candidate

Adrian Hey ahey at
Fri Sep 14 02:50:47 EDT 2007

Ian Lynagh wrote:
> This is a symptom of the stage2 build failure, meaning the installer is
> using the stage 1 compiler which can't do bytecode compilation.
> Therefore this should also be fixed in the next snapshot.

OK. Meanwhile I've tried compiling setup.hs and building the
6.6 version of the collections package..

I get this error..

[29 of 53] Compiling Data.Tree.AVL.Join (
Data.Tree.AVL/Data/Tree/AVL/Join.hs, dist\build/Data/Tree/AVL/Join.o )
ghc.exe: panic! (the 'impossible' happened)
   (GHC version 6.8.20070912 for i386-unknown-mingw32):
     a{v sMX} [lid]
     static binds for:
     collections-0.3:Data.Tree.AVL.Join.poly_go{v rse} [gid]
     collections-0.3:Data.Tree.AVL.Join.poly_$wlgo{v rsf} [gid]
     collections-0.3:Data.Tree.AVL.Join.flatConcat{v ryL} [gid]
     local binds for:
     SRT label collections-0.3:Data.Tree.AVL.Join.$LrMelvl{v rMe}_srt

Please report this as a GHC bug:

BTW, if you want to reproduce this the cabal files needs this line..
build-depends:  base >= 2.0, QuickCheck, bytestring >= 0.9, containers
>= 0.1, array >= 0.1

Adrian Hey

More information about the Glasgow-haskell-users mailing list