Problem compiling 6.8.1 extralibs

Alexis Hazell at
Wed Nov 7 20:05:24 EST 2007

On Thursday 08 November 2007 04:41, Duncan Coutts wrote:

> Install happy from
> Note that happy 1.17 needs Cabal-1.2 and 1.16 needs Cabal-1.1.6.

Ah, that would be the problem then . . . . i'm upgrading from GHC 6.4.2, and 
so have Cabal 1.1.4. Perhaps the relevant configure script should check to 
see not only if happy is installed, but whether it's a recent enough version?

> Alternatively, don't build the extralibs at the same time as ghc and
> install just the ones you need individually later. They're all available
> on hackage.

*nod* That looks like my best option, at least until i install Mandriva 2008, 
which will presumably include more recent versions of GHC etc. . . . .

Thanks for your help!


More information about the Glasgow-haskell-users mailing list