GHC.Prim problem

Ben Sinclair bsinclai at
Thu May 31 03:38:57 EDT 2007

On Tue, May 29, 2007 at 04:05:49PM +0100, Simon Marlow wrote:
> Ben Sinclair wrote:
> >Hello, I've had a problem with GHC.Prim when compiling the darcs HEAD
> >lately. When I compile it in the normal way with no special options
> >
> >>Main.hs:3:0:
> >>    Failed to load interface for `GHC.Prim':
> >>      locations searched:
> >>	GHC/Prim.hs
> >>	GHC/Prim.lhs
> It works for me, with last night's HEAD build.  Are you running GHC from 
> the build tree, or installing it first?  (not that it ought to make a 
> difference). If you say 'ghc-pkg describe base', does it list GHC.Prim as 
> exposed?

I tried again with a source tree fresh from "darcs get --partial" and
got the same result as before. "ghc-pkg describe base" doesn't mention
GHC.Prim, but it does mention GHC.PrimopWrappers, I don't know if
that's helpful. The documentation for GHC.Prim does get built.

I wouldn't think it would matter, but I'm compiling with GHC 6.6 from
Debian, which does have GHC.Prim exposed in the base package.



More information about the Glasgow-haskell-users mailing list