Problems building GHC

Peter Tanski p.tanski at
Fri Jan 12 10:12:22 EST 2007


Rodrigo Geraldo wrote:
> I start to "hack" GHC, and, I 've tried to build it, but the build  
> return
> this error message :
> configure: GMP_CHECK_ASM_W32: fatal: do not know how to define a 32- 
> bit word
> make[1]: *** [boot] Error 1
> I've tried to build GHC using mSYS and MinGW under MS windows xp...

This is an error from the internal GMP library's configure file, $ 
(top_level)/rts/gmp/configure.  If you don't have gmp installed  
already, the GHC build system tries to build it for you.  The build  
system for gmp is very delicate so I would suggest downloading a  
separate gmp library and installing that in your /usr/lib directory  
(for MinGW).  The gmp library and header file for MinGW, avaliable  
from under 'gmp-static- 
mingw-4.1.tar.gz'.  Once you have the library installed properly, the  
GHC build system will find it and won't attempt to build gmp.

I know it sounds like a workaround--we really ought to ensure the gmp  
build itself works--but in this case it is the gmp build that fails  
('s problem, not ours) and the current gmp system should be  
replaced soon by another library.  (I am working on that but for lack  
of time I am running a bit late.)

Peter Tanski

More information about the Glasgow-haskell-users mailing list