Problem compiling GHC

Cristian Perfumo cperfumo at
Mon Feb 26 08:48:38 EST 2007

Hi all,
I'm having a problem when I try to compile GHC. I did it several times
before without any problem but I don't know exactly from which moment it
started giving me errors. Anyway, I have some clues:

1) I was modifying some STM stuff and I was receiving errors with (I think)
out of date information. Then I did "make clean" in "compiler" and in
2) I don't know if this has to do but some time ago I installed FilePath
library and I hadn't executed "make clean" from this moment on.

I insist, these two items are only more information but I'm not sure they're
related with the error.
So, what I did, to be sure that the error had nothing to do with my
modification, was to download GHC again and try to build the original
version. But I still get the same error (that I paste below this message).
Thank you very much in advance for any help.
Cristian Perfumo

== make boot -r;
 in /home/cperfumo/ghc/ghc-6.6-original/ghc-6.6/includes
../utils/mkdependC/mkdependC -f .depend     -- -O -I. -I../rts    --
== make boot -r;
 in /home/cperfumo/ghc/ghc-6.6-original/ghc-6.6/compat
../utils/mkdependC/mkdependC -f .depend    -I. -Iinclude -I../includes  --
-O -I. -Iinclude -D__GHC_PATCHLEVEL__=0 -I../libraries/base/cbits
-I../libraries/base/include    -- cbits/directory.c cbits/rawSystem.c
/usr/local/bin/ghc -M -optdep-f -optdep.depend  -osuf o
-optdep--exclude-module=System.Directory.Internals   -H16m -O -I. -Iinclude
-Rghc-timing -ignore-package Cabal -I../libraries -fglasgow-exts -no-recomp
Compat/Directory.hs Compat/RawSystem.hs Compat/Unicode.hs
Distribution/Compat/FilePath.hs Distribution/Compat/ReadP.hs
Distribution/Compiler.hs Distribution/GetOpt.hs
Distribution/InstalledPackageInfo.hs Distribution/License.hs
Distribution/Package.hs Distribution/ParseUtils.hs Distribution/Version.hs

    Could not find module `System.Directory':
      Use -v to see a list of the files searched for.
<<ghc: 8676376 bytes, 5 GCs, 84456/84456 avg/max bytes residency (1
samples), 17M in use, 0.00 INIT (0.00 elapsed), 0.01 MUT (0.12 elapsed),
0.00 GC (0.01 elapsed) :ghc>>
make[1]: *** [depend] Error 1
make: *** [stage1] Error 1
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Glasgow-haskell-users mailing list