upgrading visual studio integration to use 6.8.2....

Krasimir Angelov kr.angelov at gmail.com
Fri Dec 14 05:00:40 EST 2007

The hard work is to integrate it with the new version of Cabal. The
problem is that the configurations model that Cabal employs can't be
easily matched with the configurations in Visual Studio. For the new
GHC versions I expect that the changes will be more trivial.


On Dec 13, 2007 6:23 PM, Nicholls, Mark <Nicholls.Mark at mtvne.com> wrote:
> Ahhh ok....in eclipse it was trivial.....but I'd much prefer it to be in
> VS.
> -----Original Message-----
> From: Simon Marlow [mailto:simonmarhaskell at gmail.com]
> Sent: 13 December 2007 16:22
> To: Nicholls, Mark
> Cc: glasgow-haskell-users at haskell.org
> Subject: Re: upgrading visual studio integration to use 6.8.2....
> Nicholls, Mark wrote:
> > I've just downloaded the vs integration package....which looks
> great....but
> > it comes with 6.6.1, and I was hoping to move to 6.8.2....does anyone
> know
> > how to do this?
> No, someone needs to rebuild Visual Haskell using 6.8.2, and test it
> etc.
> There have been lots of changes in both the GHC API and Cabal, so I
> expect
> it will not be a straightforward recompile.  Also building Visual
> Haskell
> itself is no mean feat.
> We'd love it if someone were able to take this on.  The code for Visual
> Haskell is available at http://darcs.haskell.org/vshaskell.
> Also, we need to update it for VS 2008...
> Cheers,
>        Simon
> _______________________________________________
> Glasgow-haskell-users mailing list
> Glasgow-haskell-users at haskell.org
> http://www.haskell.org/mailman/listinfo/glasgow-haskell-users

More information about the Glasgow-haskell-users mailing list