GHC 6.8.1 on Mac OS 10.5 Leopard (Intel) - Configure fails

Carsten Keßler carsten.kessler at
Mon Dec 10 11:22:54 EST 2007

No, I'm using the binaries from

I have already removed GMP. I have uninstalled it via Macports, or might 
there be another version of it somewhere in my system?


Joel Reymont schrieb:
> I think what I did is remove GMP.framework when building from source and 
> install the MacPorts version. Haven't had a problem since and don't 
> remember why I had the problem in the first place.
> Are you building from source?
> On Dec 10, 2007, at 3:50 PM, Carsten Keßler wrote:
>> Hi,
>> I know this issue has been discussed on the list before, but I have 
>> not found a solution in the archives. Running ./configure on Mac OS 
>> 10.5 (Intel) is aborted with this error message:
>> checking build system type... i386-apple-darwin9.1.0
>> checking host system type... i386-apple-darwin9.1.0
>> checking target system type... i386-apple-darwin9.1.0
>> Which we'll further canonicalise into: i386-apple-darwin
>> checking for path to top of build tree... dyld: Library not loaded: 
>> GMP.framework/Versions/A/GMP
>>  Referenced from: /Users/Carsten/Desktop/ghc-6.8.1/utils/pwd/pwd
>>  Reason: image not found
>> configure: error: cannot determine current directory
> -- 

Carsten Keßler
Institute for Geoinformatics, University of Münster

More information about the Glasgow-haskell-users mailing list