Bad interface file error with GHC RC2

Krasimir Angelov kr.angelov at
Thu Oct 5 06:01:13 EDT 2006

I am using something like this:

c:\ghc\ghc-6.5.20061001\bin\runghc Setup.lhs ....

for building. So an old binary shouldn't matter. With -v option I saw that:

 -package comlib

is passed. Is it possible to have .tar.gz bundle compiled with an old
Cabal? I suppose that runghc is always using ghc from its own
directory instead of those in the path.


On 10/5/06, Simon Marlow <simonmarhaskell at> wrote:
> Krasimir Angelov wrote:
> > Building with -package-name comlib-0.1 helps. I saw that Cabal from
> > HEAD is passing the full package id to GHC but the version compiled in
> > ghc-6.5.20061001 is passing just the package name. Maybe the change
> > wasn't merged in GHC-6.6 branch or the bundle wasn't build from the
> > actual sources.
> I just looked in the Cabal sources from the 6.6 branch:
>       let ghcArgs =
>                  pkg_conf
>               ++ ["-package-name", showPackageId (package pkg_descr) ]
> So it certainly passes the entire package ID (including the version) to GHC.  So
> I'm confused!  Could you perhaps have an old Setup binary left in your build tree?
> Cheers,
>        Simon

More information about the Glasgow-haskell-users mailing list