Problems building HEAD

Reilly Hayes rfh at
Tue May 9 16:18:54 EDT 2006


Thanks for all your help.

I've tried file individual messages when I'm pretty sure I've  
identified a problem with the distribution itself.  However, I  
thought it might be useful to post more on my experiences in creating  
this build.


The way I built the registerised .hc files in the original e-mail  
missed several.  However, doing a vanilla make with the following mk/ file will generate them:

SRC_HC_OPTS     = -H32m -O -fasm -Rghc-timing -keep-hc-files
GhcStage1HcOpts = -O0 -DDEBUG
GhcLibHcOpts    = -O
GhcLibWays      =
SplitObjs       = NO

make hc-file-bundle Project=ghc creates the tar file with the hc files.

2) REGISTERISED HC FILE BOOT (on Mac OS X 10.4.6 x86)

On May 2, 2006, at 4:51 AM, Simon Marlow wrote:

> I'm guessing the sequence should be something like this:
> ./configure --enable-hc-boot
> $MAKE -C utils/mkdependC boot all
> $MAKE -C includes boot all
> $MAKE -C rts boot all
> $MAKE -C libraries boot all GhcBootLibs=YES
> $MAKE -C compat boot all
> $MAKE -C utils boot all
> $MAKE -C compiler boot all
> Try that, and let me know how far you get.
> Cheers,
> 	Simon

I've managed to build a stage1 compiler that executes, but I'm not  
sure it works.  I tried a hello world test program as suggested in  
the documentation.  It fails to compile because it can't find the .hi  
files for the prelude.  But, if I understand correctly, I won't  
have .hi files until I've rebuilt the libraries with the stage1  
compiler.  Is this right?

3) Refinements to your directions

The following need to be made prior to building RTS

$MAKE -C utils/unlit boot all
$MAKE -C utils/mkdirhier boot all
$MAKE -C driver/mangler

The RTS build generates endless warnings about .o files having no  
symbols and functions not having previous prototypes.  I googled for  
both and is seems that it is OK, but I would like confirmation.

utils/genprimopcode is problematic.  The libraries build fails  
without it, but it wants the libraries to be built in order to link.   
SOMEHOW (I think by typing 'make' at the top level) I ended up with a  
viable executable for this.  Unfortunately, I can't recreate it from  
scratch.  Now that I have it, I admit that I've taken to using it to  
salt new builds rather than figure out what is going on.

The following

readline and ncurses are problematic on the Mac and should be  
replaced with verisons from gnu.  Thanks to whoever posted bug #766,  
I used the following procedure prior to running configure.

	o  Download ncurses and readline and install them into /usr/local/ 
lib.  Be sure to build ncurses as shared.
	o  set & export  LD_FLAGS=-L/usr/local/lib and CPP_FLAGS=-I/usr/ 
	o  make sure these are in your environment when you configure and do  
your build.


Reilly Hayes

More information about the Glasgow-haskell-users mailing list