6.4.2 Build error

Sven Panne Sven.Panne at aedion.de
Wed Apr 26 03:29:22 EDT 2006

Am Montag, 24. April 2006 11:11 schrieb Simon Marlow:
> Daniel Fischer wrote:
> > When building 6.4.2 today, make died with
> >[...]
> If you don't need OpenAL or ALUT, then I suggest you configure with
> --disable-openal.
> OpenAL was updated in 6.4.2.  I thought the new version handled
> compatibility with different versions of the OpenAL library better
> (indeed that's why it was updated), but it appears not.  I'm hoping Sven
> Panne, the author of OpenAL, will be able to shed some light.

*sigh* It looks like if the OpenAL package has been built correctly, but now 
the ALUT package makes some trouble. :-P I'll have a look into it at the 
weekend, in the meantime "--disable-alut" will probably help, disabling 
OpenAL itself is not needed.

Sorry for all the trouble, but the OpenAL and ALUT libraries have been a 
moving target in the past, but things have consolidated recently. Alas, some 
Linux/*BSD/... distributions are still shipping very old stuff. Catching all 
these differences via autoconf is non-trivial.


More information about the Glasgow-haskell-users mailing list