GHC-6.4.1 on FreeBSD-amd64 port progress

Simon Marlow simonmar at
Tue Oct 18 06:20:26 EDT 2005

On 17 October 2005 19:19, Wilhelm B. Kloke wrote:

> Simon Marlow <simonmar at> schrieb:
>> On 15 October 2005 23:10, Wilhelm B. Kloke wrote:
>>> Don't forget to delete Linker.c (for ghci). The stage on teh host
>>> system where the process fails jsut now is
>>>> $MAKE -C libraries boot all
>>> because
>>>> Fake happy is not happy!
>> You mean on the target system?  Can you give more details?
> Yes. Sorry for any confusion. The happy error messages was an easy
> one, 
> because I have a working 32bit happy on the system.
>>> But ghc-inplace seems to work pretty good now on amd64.
> I reached the end of hc-build successfully. Now there is a new
> problem. 
> I tried (as root) make install at this point. This fails with error
> messages 
> related to missing stage2 subdirectories. So I tried

At this point you can either do 'make install stage=1', or you can just
use the compiler you built to build a clean GHC in another tree, i.e.
with ./configure --with-ghc=/path/to/bootstrap/ghc/compiler/ghc-inplace.

> gmake stage=2 boot
> This fails with messages
> ...
> cmm/CmmLex.hs:28: unterminated #if
> cmm/CmmLex.hs:20: unterminated #if
> <<ghc: 55123864 bytes, 6 GCs, 160600/160600 avg/max bytes residency
> (1 samples), 16M in use, 0.00 INIT (0.00 elapsed), 0.12 MUT (0.41
> elapsed), 0.01 GC (0.05 elapsed) :ghc>> gmake: *** [depend] Fehler 1 
> This error is due to indented preprocessor lines
> 			#else
> 			#endif

I've never seen this one before - very odd.  You must have Alex in order
to process CmmLex.x into CmmLex.hs, or did you copy this from the host
tree?  I just checked and a copy of CmmLex.hs from my build tree doesn't
have any indented preprocessor directives.


More information about the Glasgow-haskell-users mailing list