Haskell on Red Hat Enterprise...

Andy Moran moran at galois.com
Thu Mar 17 10:44:43 EST 2005

Tomasz Zielonka wrote:
> On Thu, Mar 17, 2005 at 10:02:56AM -0500, Francois Meehan wrote:
>>Hi all,
>>I need Haskell to be installed on a Red advance server 3. Could not find
>>for it. Tried compiling for tar file, won't pass the ./configure, giving
>>me "configure: error: GHC is required unless bootstrapping from .hc
>>files." error.
>>Could someone give me some pointers on how to do this?
> I was installing GHC 6.2.2 on RH AS r3 on x86 recently and the generic
> binary distribution for "Generic Linux with glibc 2.3" worked fine. Just
> download it from the website, configure, make in-place, and you have a
> working GHC in 5 minutes. You can use this GHC to compile another, newer
> versions. There is a generic binary x86/Linux glibc 2.3 version of GHC
> 6.4 on the website too.

This was my experience on Fedora Core 3 too.

If building on RHEL3 or FC3, you will likely need to "./configure 
--with-gcc=gcc33" (provided you have gcc-compat installed). The latest 
gcc on these systems is 3.4. With 3.4, changes were made to the 
-traditional version of the C preprocessor that make it incompatible 
with the way in which many of the Haskell modules in the GHC source tree 
reify make/build variables as Haskell strings.

Have we converged on a long-term solution for this problem? Is hscpp 
ready for the job?



Andy Moran                                      Ph. (503) 626 6616, x113
Galois Connections Inc.                              Fax. (503) 350 0833
12725 SW Millikan Way, Suite #290                  http://www.galois.com
Beaverton, OR 97005                                     moran at galois.com

More information about the Glasgow-haskell-users mailing list