GHC 6.4 release candidates available (breakage on suse 9.2 x86 or x86-64)

Simon Marlow simonmar at
Wed Feb 23 09:08:33 EST 2005

On 23 February 2005 11:01, Brian Strand wrote:

> Thanks a lot!  For anyone who runs into the same problem, here is
> what I did:
> 1. Converted to an rpm via "alien -r ghc6_6.2.2-3_amd64.deb"
> 2. Installed the resulting rpm.
> 3. When I tried to run ghc6, I got
> /usr/lib/ghc-6.2.2 # /usr/bin/ghc6
> ghc-6.2.2: Can't find package.conf as
> /usr/lib/ghc-6.2.2/ghc/driver/package.conf.inplace
> Other similar errors cropped up while trying to bootstrap.  So, some
> crude symlink hackery:
> cd /usr/lib/ghc-6.2.2
> ln -s . ghc
> ln -s . driver
> ln -s package.conf.shipped package.conf.inplace
> # now we have a /usr/lib/ghc-6.2.2/ghc/driver/package.conf.inplace
> mkdir utils
> ln -s .. utils/unlit
> # now we have a /usr/lib/ghc-6.2.2/utils/unlit/unlit
> ln -s ghc6 /usr/bin/ghc
> # so ./configure finds ghc
> This has gotten me quite a ways into the 6.2.2 compile; I'm still
> waiting to see if it completes successfully.

Just to let you know, there are a number of open bug reports for GHC on
the x86_64 platform, which seem to indicate some kind of occasional
memory/GC problem.  I'm probably not going to be able to track this down
until after the 6.4 release, but we'll put out a patch as soon as we
have one.


More information about the Glasgow-haskell-users mailing list