compiling GHC with a custom path to GCC

Simon Marlow simonmar at
Thu Feb 17 06:54:52 EST 2005

On 17 February 2005 11:49, Seth Kurtzberg wrote:

> Simon Marlow wrote:
>> On 17 February 2005 11:12, Remi Turk wrote:
>>> when compiling the new ghc pre-releases made my gcc 2.95.3 die
>>> with "internal compiler error", I tried to compile it with gcc
>>> 3.4.3 (or rather, I thought it compiled with 3.4.1, and when that
>>> died, compiled+installed gcc 3.4.3, tried again, say it die again
>>> and only then noticed it was actually still using 2.95.3 ;) but
>>> had quite some difficulty to actually get it to compile with, in
>>> my case, /usr/local/bin/gcc3
>>> When using the following command-line
>>> CC=gcc3 CXX=g++3 nice ./configure --enable-hopengl
>>> --prefix=/var/tmp/ghc --with-gcc=/usr/local/bin/gcc3
>>> stage1 still used gcc 2.95.3 to compile stage2 (okay, for
>>> --with-gcc that's documented) 
>> Really?  --with-gcc should set the gcc for stage1, AFAIK.  Is there
>> a bug here? 
>> I've noticed gcc 2.95 crashing on my FreeBSD box too.  I should look
>> into whether there's a workaround, otherwise we're hosed on FreeBSD
>> 4.x. 
> This is a known problem in all the 3.x compilers, and also occurs,
> although less often, with 2.9x versions.  I've seen no difference in
> frequency comparing FreeBSD to Linux and NetBSD.
> The only solution, which is of course highly annoying, is to simply
> restart the make.  For whatever reason this always works, sometimes
> until the end of the build, and sometimes until some other crash.  My
> theory is that it is related to the temporary files that gcc creates,
> mostly for templates.
> While a royal PITA, the resulting code is correct.

A known problem?  Is there any open bug in the gcc bug database I can
look at?


More information about the Glasgow-haskell-users mailing list