STM check/MonadPlus

Remi Turk rturk at
Mon Feb 7 06:51:43 EST 2005

On Mon, Feb 07, 2005 at 10:53:36AM -0000, Simon Peyton-Jones wrote:
> Thanks for the typo.  Yes, for Haskell guys 'guard' is fine; but the
> main audience for the paper is non-haskell folk, so we have to spell out
> the defn.
> S

Hm, what about calling it `guard' and adding a footnote saying
that in Haskell its type is actually more general? It smells a
bit like namespace pollution to me right now. (Says he who hasn't
even compiled 6.3 since STM got in ;)


More information about the Glasgow-haskell-users mailing list