[STM] Better name for waitUntil?
tomasz.zielonka at gmail.com
Fri Dec 23 11:09:48 EST 2005
On Fri, Dec 23, 2005 at 03:45:54PM -0000, Simon Marlow wrote:
> How about
> retryIfEarlierThan / retryIfLaterThan
> retryIfBefore / retryIfAfter
> I like making it clear that the operation behaves like retry given
> certain conditions.
I like these proposals! Thanks!
I think I prefer the retryIfBefore/retryIfBefore version.
In a private email Simon Peyton-Jones proposed retryBefore / retryAfter.
It's interesting that you think so similarly ;-)
This also convinces me that these are the best names.
I was going to release a cabal package with these functions a week ago,
but life didn't allow me to. Stay tuned ;-)
I am searching for a programmer who is good at least in some of
[Haskell, ML, C++, Linux, FreeBSD, math] for work in Warsaw, Poland
More information about the Glasgow-haskell-users