[STM] Better name for waitUntil?

Tomasz Zielonka tomasz.zielonka at gmail.com
Mon Dec 19 04:28:18 EST 2005


I am finishing my waitUntil implementation for STM. It's a new
STM action that will allow to wait for a given time point.

    waitUntil :: UTCTime -> STM ()

(UTCTime is from Ashley Yakeley's Time library.)

The intended semantics is that

    waitUntil t

will succeed as soon as time passes t, or more precisely when (now >= t).

Right now I am to find a better name for waitUntil. Maybe it should be
more declarative, like "itsAfter" or "timeAfter"? I am not a native english
speaker, so I am probably missing many options. Any ideas?

I also think about adding something like "itsBefore", which would mean
(now < t).

How about "it'sAfter" ?
Maybe only "after", without "it's" ?

Thanks in advance for your help.

PS. I imagine that it would be possible to implement waitUntil more
    efficiently in GHC's RTS, but my implementation can be a nice
    showcase for STM's expressivity, and it's still quite efficient
    (I used some (quite elegant :) hacks to implement subsecond
    precision waitUntil efficiently).

Best regards

I am searching for a programmer who is good at least in some of
[Haskell, ML, C++, Linux, FreeBSD, math] for work in Warsaw, Poland

More information about the Glasgow-haskell-users mailing list