Network.Socket on win32

haskell at haskell at
Tue Mar 2 09:44:04 EST 2004

Yup that worked.  Sort of an obscure error message
to communicate "package not found"....

Is there a convention so I know which package I
need for which module?  My guess is sometimes (but
randomly) you need to add a package
on the command line corresponding to the first
part of the qualified module name.  e.g. I just
figured out that

-package text worked to get me Text.ParserCombinators.Parsec

OTOH, if this is the rule, it seems strange that
GHC can't go and find the packages itself.


On Tue, 2 Mar 2004, Simon Marlow wrote:

> > This program does not compile using GHC 6.2 on winXP.
> >
> >   import Network.Socket
> >   main = do putStr ""
> >
> > The error is:
> >
> >   conc.o(.text+0x22):fake: undefined reference to
> > `__stginit_NetworkziSocket_'
> >
> > What am I doing wrong?
> You need to add '-package network' to the command line when linking, or
> compile the program with --make.
> Cheers,
> 	Simon

S. Alexander Jacobson                  mailto:me at

More information about the Glasgow-haskell-users mailing list