GHC 5.02.2 installation/compilation problems

Simon Marlow
Fri, 25 Jan 2002 09:46:09 -0000

Hi Nick,

> I just installed GHC 5.02.2 (actually, the latest version=20
> from CVS), and
> had a strange problem.  My first attempt worked ok, but I=20
> screwed something
> up, so I junked it and started again from scratch.
> This time, it died part-way through the "make boot" step for ghc
> itself, because glafp-utils/mkdependC/mkdependC had not been=20
> built. To fix
> the problem I just went to that directory and made mkdependC=20
> myself first,
> and then recompiled from $(BUILD), which worked.  Does anyone have any
> idea why mkdependC may not have been built in the first place?

Nothing springs to mind, unless you had explicitly set
$(ProjectsToBuild) in your, and left out glafp-utils.  It
usually isn't necessary to set $(ProjectsToBuild) as it defaults to
building all the projects in the current tree.

> Also, when I try to compile for ticky-ticky profiling by setting
> GhcCompilerWays=3Dt and GhcLibWays=3Dt in $(BUILD)/mk/, and =
> running "make all" in $(BUILD), it compiles for a short time=20
> and then dies
> with this error message:

Just set GhcLibWays=3Dt, you don't have to set GhcCompilerWays too (this
is for building the compiler itself in a different way).