GHC 5.02.2 installation/compilation problems

Nicholas Nethercote
Fri, 25 Jan 2002 09:23:25 +0000 (GMT)


I just installed GHC 5.02.2 (actually, the latest version from CVS), and
had a strange problem.  My first attempt worked ok, but I screwed something
up, so I junked it and started again from scratch.

This time, it died part-way through the "make boot" step for ghc
itself, because glafp-utils/mkdependC/mkdependC had not been built. To fix
the problem I just went to that directory and made mkdependC myself first,
and then recompiled from $(BUILD), which worked.  Does anyone have any
idea why mkdependC may not have been built in the first place?

Also, when I try to compile for ticky-ticky profiling by setting
GhcCompilerWays=t and GhcLibWays=t in $(BUILD)/mk/, and then
running "make all" in $(BUILD), it compiles for a short time and then dies
with this error message:

 <lots of stuff...>
 ==fptools== make way=t all;
 PWD = /local/scratch-1/njn25/ws/build/ghc/compiler
 /homes/njn25/local/bin/ghc-5.02.2 -o ghc_t-5.03 -ldl -cpp ... <many files>
 /usr/bin/ld: cannot find -lHSutil_t
 collect2: ld returned 1 exit status
 <<ghc: 4187340 bytes, 2 GCs, 126260/126260 avg/max bytes residency (1
 samples), 5M in use, 0.01 INIT (0.00 elapsed), 0.01 MUT (0.32 elapsed),
 0.03 GC (0.03 elapsed) :ghc>>
 make[3]: *** [ghc_t-5.03] Error 1
 make[2]: *** [all] Error 1
 make[1]: *** [all] Error 1
 make[1]: Leaving directory `/local/scratch-1/njn25/ws/build/ghc'
 make: *** [all] Error 1

Am I doing something wrong?  Has something been broken in 5.02.2?

In case it's useful, here's the exact steps I took:

- CVS checkout happy, ghc, hslibs
- make build tree with sym links to code tree
- run autoconf in $(BUILD) and in ghc/$(BUILD)
- run ./configure in $(BUILD), with apt. --prefix and --with-ghc values
- create $(BUILD)/mk/

 	ProjectsToBuild = happy hslibs ghc

  (for ticky-ticky profiling, I added "t" to the last two lines)

- run "make all" in $(BUILD)

Thanks for the help.
Nick Nethercote