GHC 5.02 source RPM

Arjen P. de Vries
Mon, 17 Dec 2001 10:48:18 +0100


does anyone know how to solve the following problem?

I build the ghc from the source RPM, and everything goes fine up to creating
the binary rpms as final result, but then it does not want to install
the created binary rpm, due to dependency on
  error: failed dependencies:
        /usr/local/bin/perl   is needed by ghc-5.02.1-1
I tried to fix it in the SPEC file, but could not find where the Requirement
on /usr/local/bin/perl is specified (it does not seem to be there).

BTW, I do have a /usr/local/bin/perl but apparently rpm does not understand;
of course, after --nodeps it installs, but I need to solve the dependency
problem since I also use apt.

Tnx for any clues,


CWI, room C0.11          Centre for Mathematics and Computer Science
Kruislaan 413                           Email:
1098 SJ Amsterdam                       tel:       +31-(0)20-5924306
The Netherlands                         fax:       +31-(0)20-5924312  
===================== ====================