Problems with libgmp

Simon Marlow
Thu, 16 Nov 2000 01:57:00 -0800

> > > So, I can't quite work out what went wrong in your case.  
> If the build
> > > didn't detect GMP 2, then it should have just used the 
> one in the tree.
> > 
> > Obviously, when linking, it did not use the one in the tree :-(
> > Conclusion: The Linux linker does not behave like other linkers or
> > there is a bug in some Makefile.
> Of late I have had problems with libgmp2 and woody-debian. I 
> solved the
> problem the first time around by adding a sym link 
> /usr/lib/ ->
> /usr/lib/
> Yesterday I solved the problem by installing libgmp2-dev 
> because ld was
> looking for libgmp.a for some reason when trying to compile hdirect.
> Hacks at best. Haven't really looked for whys and wherefores.

The binary distributions of 4.08.2 will come with a statically linked

It's up to the package maintainers (RedHat RPM, Debian etc.) to decide
the best approach for those systems, i.e. whether it's better to depend
on the system-supplied shared libgmp or supply one in the GHC package.
On FreeBSD for example I just use the system-supplied one since it's
part of the base system.