[GHC] #4148: improve new recursive do syntax
GHC
cvs-ghc at haskell.org
Fri Jun 8 16:12:10 CEST 2012
#4148: improve new recursive do syntax
---------------------------------+------------------------------------------
Reporter: guest | Owner:
Type: feature request | Status: patch
Priority: low | Milestone: 7.6.1
Component: Compiler | Version: 6.12.3
Keywords: | Os: Unknown/Multiple
Architecture: Unknown/Multiple | Failure: None/Unknown
Difficulty: Unknown | Testcase:
Blockedby: | Blocking:
Related: |
---------------------------------+------------------------------------------
Comment(by simonpj):
Levent: Thanks. I'd forgotten that the `mdo` keyword etc was still there;
splendid. As you say, quite easy.
I think Ross is right about the documentation. What do you think?
Last issue: do we really want two flags? I think not.
'''Proposal'''. I suggest we deprecate `DoRec` in favour of the (less-
cryptic) `RecursiveDo`.
For now they can be synonymous. (I know that previously we deprecated
`RecursiveDo` in favour of `DoRec` but we really have changed course
here.) Anyone disagree?
Simon
--
Ticket URL: <http://hackage.haskell.org/trac/ghc/ticket/4148#comment:27>
GHC <http://www.haskell.org/ghc/>
The Glasgow Haskell Compiler
More information about the Glasgow-haskell-bugs
mailing list