[GHC] #974: Add unzipEithers, lefts, rights to Data.Either
GHC
trac at galois.com
Fri Nov 3 09:55:06 EST 2006
#974: Add unzipEithers, lefts, rights to Data.Either
----------------------------+-----------------------------------------------
Reporter: guest | Owner:
Type: proposal | Status: new
Priority: normal | Milestone:
Component: libraries/base | Version: 6.6
Severity: normal | Resolution:
Keywords: | Difficulty: Unknown
Testcase: | Architecture: Unknown
Os: Unknown |
----------------------------+-----------------------------------------------
Comment (by guest):
Some suggest partitionEithers is a better name than unzipEithers because
unzipEithers suggests that there is some sort of zipEithers.
One concern is that partitionEithers is long for an identifier, but 16
characters isn't unusually long for an identifier.
--
Ticket URL: <http://hackage.haskell.org/trac/ghc/ticket/974>
GHC <http://www.haskell.org/ghc/>
The Glasgow Haskell Compiler
More information about the Glasgow-haskell-bugs
mailing list