[GHC] #13145: Documentation shouldn't call things functions that aren't functions

GHC ghc-devs at haskell.org
Wed Jan 18 02:43:23 UTC 2017


#13145: Documentation shouldn't call things functions that aren't functions
-------------------------------------+-------------------------------------
        Reporter:  chris-martin      |                Owner:
            Type:  bug               |               Status:  new
        Priority:  normal            |            Milestone:
       Component:  libraries/base    |              Version:  8.0.1
      Resolution:                    |             Keywords:
Operating System:  Unknown/Multiple  |         Architecture:
 Type of failure:  Documentation     |  Unknown/Multiple
  bug                                |            Test Case:
      Blocked By:                    |             Blocking:
 Related Tickets:                    |  Differential Rev(s):
       Wiki Page:                    |
-------------------------------------+-------------------------------------
Description changed by chris-martin:

@@ -0,0 +1,5 @@
+ Referring to non-function values (particularly of type `IO`) as
+ "functions" is often a sign that beginners haven't fully grasped some
+ concepts about purity, so I think it's important to clean up our own
+ language.
+
@@ -15,5 +20,0 @@
-
- Referring to non-function values (particularly of type `IO`) as
- "functions" is often a sign that beginners haven't fully grasped some
- concepts about purity, so I think it's important to clean up our own
- language.

New description:

 Referring to non-function values (particularly of type `IO`) as
 "functions" is often a sign that beginners haven't fully grasped some
 concepts about purity, so I think it's important to clean up our own
 language.

 For example, in the
 [https://hackage.haskell.org/package/base-4.9.0.0/docs/Prelude.html
 Prelude] docs we have a section called "Input functions" in which only one
 of the four values is a function:

 {{{
 getChar :: IO Char
 getLine :: IO String
 getContents :: IO String
 interact :: (String -> String) -> IO ()
 }}}

 In that case, I suggest we rename the sections "Input functions" and
 "Output functions" to simply "Input" and "Output".

--

--
Ticket URL: <http://ghc.haskell.org/trac/ghc/ticket/13145#comment:3>
GHC <http://www.haskell.org/ghc/>
The Glasgow Haskell Compiler


More information about the ghc-tickets mailing list