[GHC] #13545: Remove duplication between lookupSubBndrOcc and lookupExportChild
GHC
ghc-devs at haskell.org
Fri Apr 7 18:43:58 UTC 2017
#13545: Remove duplication between lookupSubBndrOcc and lookupExportChild
-------------------------------------+-------------------------------------
Reporter: mpickering | Owner: (none)
Type: task | Status: new
Priority: normal | Milestone:
Component: Compiler | Version: 8.0.1
Keywords: | Operating System: Unknown/Multiple
Architecture: | Type of failure: None/Unknown
Unknown/Multiple |
Test Case: | Blocked By:
Blocking: | Related Tickets:
Differential Rev(s): | Wiki Page:
-------------------------------------+-------------------------------------
`lookupSubBndrOcc` is used in expressions such as `x { y = 5 }` to resolve
field labels such as `y`.
`lookupExportChild` is used in export lists such as `T(A, x)` to lookup
`A` and `x`.
They contain very similar logic but it is duplicated in two places which
caused #13528.
It should be easy to refactor them them to deduplicate the logic.
--
Ticket URL: <http://ghc.haskell.org/trac/ghc/ticket/13545>
GHC <http://www.haskell.org/ghc/>
The Glasgow Haskell Compiler
More information about the ghc-tickets
mailing list