[GHC] #11357: Regression when deriving Generic1 on poly-kinded data family
GHC
ghc-devs at haskell.org
Wed Jul 20 15:16:18 UTC 2016
#11357: Regression when deriving Generic1 on poly-kinded data family
-------------------------------------+-------------------------------------
Reporter: RyanGlScott | Owner:
Type: bug | Status: closed
Priority: highest | Milestone: 8.0.1
Component: Compiler | Version: 7.11
(CodeGen) | Keywords: Generics,
Resolution: fixed | TypeInType, TypeFamilies
Operating System: Unknown/Multiple | Architecture:
| Unknown/Multiple
Type of failure: GHC rejects | Test Case:
valid program | deriving/should_compile/T11357
Blocked By: | Blocking:
Related Tickets: | Differential Rev(s):
Wiki Page: |
-------------------------------------+-------------------------------------
Comment (by Ben Gamari <ben@…>):
In [changeset:"9513fe6bdeafd35ca1a04e17b5f94732516766aa/ghc" 9513fe6/ghc]:
{{{
#!CommitTicketReference repository="ghc"
revision="9513fe6bdeafd35ca1a04e17b5f94732516766aa"
Clean up interaction between name cache and built-in syntax
This cleans up various aspects of the handling of built-in syntax in the
original name cache (hopefully resulting in a nice reduction in compiler
allocations),
* Remove tuple types from original name cache: There is really no
reason for these to be in the name cache since we already handle
them specially in interface files to ensure that we can resolve them
directly to Names, avoiding extraneous name cache lookups.
* Sadly it's not possible to remove all traces of tuples from the
name cache, however. Namely we need to keep the tuple type
representations in since otherwise they would need to be wired-in
* Remove the special cases for (:), [], and (##) in isBuiltInOcc_maybe
and rename it to isTupleOcc_maybe
* Split lookupOrigNameCache into two variants,
* lookupOrigNameCache': Merely looks up an OccName in the original
name cache, making no attempt to resolve tuples
* lookupOrigNameCache: Like the above but handles tuples as well.
This is given the un-primed name since it does the "obvious"
thing from the perspective of an API user, who knows nothing of
our special treatment of tuples.
Arriving at this design took a significant amount of iteration. The
trail of debris leading here can be found in #11357.
Thanks to ezyang and Simon for all of their help in coming to this
solution.
Test Plan: Validate
Reviewers: goldfire, simonpj, austin
Reviewed By: simonpj
Subscribers: thomie, ezyang
Differential Revision: https://phabricator.haskell.org/D2414
GHC Trac Issues: #11357
}}}
--
Ticket URL: <http://ghc.haskell.org/trac/ghc/ticket/11357#comment:15>
GHC <http://www.haskell.org/ghc/>
The Glasgow Haskell Compiler
More information about the ghc-tickets
mailing list