[ghc-steering-committee] #216: Qualified Do again, recommendation: accept the alternative

Joachim Breitner mail at joachim-breitner.de
Wed May 6 14:28:26 UTC 2020


Am Mittwoch, den 06.05.2020, 15:55 +0200 schrieb Spiwack, Arnaud:
> There is one question to solve: should we use the standard names
> `(>>=)`, `(>>)` for desugaring? (so that the type class methods can
> be used directly). Or some dedicated names `desugaringBind`, … ? To
> avoid name clashes.

given that the recommended idiom is to only use this with a qualified
module name, I think using the normal, well-known names is reasonable.

Joachim Breitner
  mail at joachim-breitner.de

More information about the ghc-steering-committee mailing list