<div dir="ltr"><div dir="ltr"><div class="gmail_default" style="font-family:times new roman,serif;font-size:large">I read the email thread you refer to but it doesn't seem to explain why you went with solution 2. If you think it worthwhile can you explain¬†here why you chose solution 2?</div></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Tue, Jun 23, 2020 at 6:55 PM Andreas Klebinger <<a href="mailto:klebinger.andreas@gmx.at">klebinger.andreas@gmx.at</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">There was a discussion about making UniqFM typed for the keys here a<br>
while ago.<br>
(<a href="https://mail.haskell.org/pipermail/ghc-devs/2020-January/018451.html" rel="noreferrer" target="_blank">https://mail.haskell.org/pipermail/ghc-devs/2020-January/018451.html</a><br>
and following)<br>
<br>
I wrote up an MR for one possible approach here:<br>
<a href="https://gitlab.haskell.org/ghc/ghc/-/merge_requests/3577" rel="noreferrer" target="_blank">https://gitlab.haskell.org/ghc/ghc/-/merge_requests/3577</a><br>
<br>
It implements solution 2 from that discussion.<br>
<br>
Just while getting the patch to typecheck I've already seen a number of<br>
cases where this increased<br>
readability of the code quite a bit so I think it's a good improvement.<br>
<br>
If there are strong objections to this solution let me know. In that<br>
case I'm happy to abandon the patch.<br>
If not I will clean it up and get it ready for merging.<br>
<br>
<br>
_______________________________________________<br>
ghc-devs mailing list<br>
<a href="mailto:ghc-devs@haskell.org" target="_blank">ghc-devs@haskell.org</a><br>
<a href="http://mail.haskell.org/cgi-bin/mailman/listinfo/ghc-devs" rel="noreferrer" target="_blank">http://mail.haskell.org/cgi-bin/mailman/listinfo/ghc-devs</a><br>
</blockquote></div></div>