<HTML><HEAD>
<META content="text/html; charset=utf-8" http-equiv=Content-Type></HEAD>
<BODY>
<DIV>
<DIV style="FONT-SIZE: 11pt; FONT-FAMILY: Calibri,sans-serif">I think this is a great idea, I was thinking of creating a ticket for it after 7.8.3 was out of the way.  In my case the reason is C++11 support, LLVM has 4.7 as the minimum version now.<BR><BR>Just having a script in git and downloading the tarballs sounds very sensible.<BR><BR>Speaking of LLVM, how about making it (optionally?) download an llvm tarball too?<BR><BR>Niklas</DIV></DIV>
<DIV dir=ltr>
<HR>
<SPAN style="FONT-SIZE: 11pt; FONT-FAMILY: Calibri,sans-serif; FONT-WEIGHT: bold">Från: </SPAN><SPAN style="FONT-SIZE: 11pt; FONT-FAMILY: Calibri,sans-serif"><A href="mailto:komadori@gekkou.co.uk">Robin KAY</A></SPAN><BR><SPAN style="FONT-SIZE: 11pt; FONT-FAMILY: Calibri,sans-serif; FONT-WEIGHT: bold">Skickat: </SPAN><SPAN style="FONT-SIZE: 11pt; FONT-FAMILY: Calibri,sans-serif">‎2014-‎06-‎10 01:46</SPAN><BR><SPAN style="FONT-SIZE: 11pt; FONT-FAMILY: Calibri,sans-serif; FONT-WEIGHT: bold">Till: </SPAN><SPAN style="FONT-SIZE: 11pt; FONT-FAMILY: Calibri,sans-serif"><A href="mailto:ghc-devs@haskell.org">ghc-devs@haskell.org</A></SPAN><BR><SPAN style="FONT-SIZE: 11pt; FONT-FAMILY: Calibri,sans-serif; FONT-WEIGHT: bold">Ämne: </SPAN><SPAN style="FONT-SIZE: 11pt; FONT-FAMILY: Calibri,sans-serif">GHC MinGW distribution</SPAN><BR><BR></DIV>Dear All,<BR><BR>I wanted to enquire about the prospects for updating the version of <BR>MinGW which ships with the Windows binary distribution of GHC. The <BR>version included as of 7.8.2 is now several years old and in some cases <BR>I've found that it's incompatible with the libraries produced by newer <BR>versions of MinGW (as to be expected, per my understanding).<BR><BR>Specifically, my HsQML binding for Qt can't be used with the libraries <BR>from the official Windows binary distribution of Qt 5 because the <BR>resulting executables crash on start-up with runtime incompatibilities. <BR>I'm in the process of trying to build out-of-the-box compatible Qt <BR>binaries against GHC's MinGW, but Qt's stated minimum requirements on <BR>the tool-chain version aren't encouraging. The only way I currently have <BR>of making this work is for users to edit their GHC settings file to <BR>point GHC at a version of gcc.exe from a newer MinGW (such as the one <BR>which ships with Qt). The fact that this seems to work is encouraging, <BR>but it's still a bit of a difficult process to put people through.<BR><BR>I know that Windows developers are in short supply, so I would like to <BR>offer what assistance I can in making this happen. There appear to be <BR>copies of MinGW stored in the GHC repository at <BR>http://git.haskell.org/ghc-tarballs.git/tree . Does the build system use <BR>these automatically or are they just there for reference?<BR><BR>Thanks,<BR><BR>-- <BR>Robin KAY<BR><BR>_______________________________________________<BR>ghc-devs mailing list<BR>ghc-devs@haskell.org<BR>http://www.haskell.org/mailman/listinfo/ghc-devs<BR></BODY></HTML>