<div dir="ltr">Hi Austin, <div><br></div><div style>I didn&#39;t have much time to look into the problem, but I did run the last command (the one that fails) and it outputs this when run with &#39;sh -x&#39;: </div><div style>
<br></div><div style><div>sh -x gen_contents_index --verbose</div><div>+ set -e</div><div>+ USAGE=&#39;Usage: gen_contents_index [--intree] [--verbose] [--help]&#39;</div><div>+ INTREE=</div><div>+ VERBOSE=</div><div>+ HADDOCK_ARGS=</div>
<div>+ &#39;[&#39; 1 -ne 0 &#39;]&#39;</div><div>+ case &quot;$1&quot; in</div><div>+ VERBOSE=yes</div><div>+ shift</div><div>+ &#39;[&#39; 0 -ne 0 &#39;]&#39;</div><div>+ &#39;[&#39; -n &#39;&#39; &#39;]&#39;</div><div>+ HADDOCK=../../../../../bin/haddock</div>
<div>++ grep -v &#39;/ghc\.haddock&#39;</div><div>++ sort</div><div>++ ls -1 &#39;*/*.haddock&#39;</div><div>ls: */*.haddock: No such file or directory</div><div>+ HADDOCK_FILES=</div><div>+ HADDOCK_ARGS=&#39;-p prologue.txt&#39;</div>
<div>+ &#39;[&#39; -n yes &#39;]&#39;</div><div>+ echo -p prologue.txt</div><div>-p prologue.txt</div><div>+ ../../../../../bin/haddock --gen-index --gen-contents -o . -t &#39;Haskell Hierarchical Libraries&#39; -p prologue.txt</div>
<div>gen_contents_index: line 80: ../../../../../bin/haddock: No such file or directory</div><div><br></div><div style>So the problem seems to be that the path to haddock in that script is bad for my setup. I haven&#39;t yet tracked down why line 80 in libraries/gen_contents_index occurs that way. It seems strange to have that path hardcoded in that way. I guess it might be generated by some earlier build scripts.  </div>
</div></div><div class="gmail_extra"><br><br><div class="gmail_quote">On Wed, Apr 3, 2013 at 1:22 PM, Austin Seipp <span dir="ltr">&lt;<a href="mailto:aseipp@pobox.com" target="_blank">aseipp@pobox.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">Andreas,<div><br></div><div>After seeing this, I updated my &#39;pristine&#39; (unmodified, completely clean) GHC tree to the latest HEAD, copied the mk/build.mk.sample over my existing <a href="http://build.mk" target="_blank">build.mk</a> (since Ian made some changes to it recently,) and HEAD builds fine for me as of this morning. I&#39;m running the testsuite now...</div>

<div><br></div><div>Specs - OS X Mountain Lion 10.8.3. My HEAD points to commit 9d33fc3c55fe5f45ebaec5f2031e63813a2ba27a by Ian this morning.</div><div><br></div><div><br></div></div><div class="gmail_extra"><br><br><div class="gmail_quote">
<div><div class="h5">
On Wed, Apr 3, 2013 at 9:08 AM, Andreas Voellmy <span dir="ltr">&lt;<a href="mailto:andreas.voellmy@gmail.com" target="_blank">andreas.voellmy@gmail.com</a>&gt;</span> wrote:<br></div></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div><div class="h5">
<div dir="ltr">I got a fresh copy of HEAD today, and the build failed. The failing command is: <div><br></div><div><div>$ cd libraries &amp;&amp; sh gen_contents_index --intree</div><div>haddock: internal error: /Users/andreas/repos/temp-ghc-2/ghc-build/inplace/lib/html/Ocean.std-theme/hslogo-16.png: copyFile: does not exist (No such file or directory)</div>


</div><div><br></div><div>I have not yet had time to look into this, but hopefully someone knows what happened here. </div><div><br></div><div>-Andi</div></div>
<br></div></div>_______________________________________________<br>
ghc-devs mailing list<br>
<a href="mailto:ghc-devs@haskell.org" target="_blank">ghc-devs@haskell.org</a><br>
<a href="http://www.haskell.org/mailman/listinfo/ghc-devs" target="_blank">http://www.haskell.org/mailman/listinfo/ghc-devs</a><br>
<br></blockquote></div><span class="HOEnZb"><font color="#888888"><br><br clear="all"><div><br></div>-- <br><div dir="ltr">Regards,<br>Austin - PGP: 4096R/0x91384671</div>
</font></span></div>
</blockquote></div><br></div>