In-tree invocation of GHC built with Hadrian

Simon Peyton Jones simonpj at
Thu Apr 4 15:40:24 UTC 2019

OK, that's great - it's not just me.   I'll await further guidance, and revert to "sh validate" meanwhile.
From: ghc-devs <ghc-devs-bounces at> On Behalf Of Alp Mestanogullari
Sent: 04 April 2019 16:25
To: ghc-devs at
Subject: Re: In-tree invocation of GHC built with Hadrian

I can reproduce this problem. This doesn't come up when building stage2 with that executable (stage1) because the commands that Hadrian emits all do something along the lines of `-no-user-package-db -package-db _build/stage0/lib/package.conf.d`, which masks the problem. I'm looking into this, I will open a ticket soon with the information that I can gather.
On 04/04/2019 13:21, Simon Peyton Jones via ghc-devs wrote:
How can I run the inplace binary built by Hadrian.  I tried this

~/code/HEAD/_build/stage0/bin/ghc -c Foo.hs
but I got this

~/code/HEAD/_build/stage0/bin/ghc -c Foo.hs

Foo.hs:1:8: error:

    Bad interface file: /opt/ghc/8.6.4/lib/ghc-8.6.4/base-

        mismatched interface file versions (wanted "80920190403", got "8064")


1 | module Foo where

  |        ^^^

simonpj at MSRC-3645512:~/tmp$
Somehow the inplace binary built by Hadrian is looking for library files in completely the wrong place.
What should I do?


ghc-devs mailing list

ghc-devs at<mailto:ghc-devs at><>


Alp Mestanogullari, Haskell Consultant

Well-Typed LLP,<>

Registered in England and Wales, OC335890

118 Wymering Mansions, Wymering Road, London, W9 2NF, England
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ghc-devs mailing list