Can't build HEAD with the old build system

Ömer Sinan Ağacan omeragacan at
Mon Apr 1 05:35:20 UTC 2019

Yeah I can reproduce it reliably. I tried a few `git clean -xfd`s, and tried
with no and with a debug, it happened with all configurations,
when building the same file (the hsc2hs executable).

The repro is simple: clone the GHC repo, build at 6f7115dfd4. If this doesn't
reproduce the bug then I don't know what else to try.

> so perhaps you also have a corrupt ELF file somewhere

How do I check this? Maybe gold.ld produces a corrupt ELF file during the build,
and then tries to read it to link an executable.


Niklas Hambüchen <mail at>, 31 Mar 2019 Paz, 23:11 tarihinde şunu yazdı:
> Can you reproduce this reliably?
> Googling the error message "internal error in find_view" yields:
> where somebody encountered it, but only in proprietary code.
> It would probably be very useful if we could provide a repro of it in an open-source code base like GHC.
> By the way, the attachment there is called "Corrupt elf file which causes linker to crash", so perhaps you also have a corrupt ELF file somewhere?
> Niklas

More information about the ghc-devs mailing list