Simon Peyton Jones simonpj at
Tue Jun 26 08:59:46 UTC 2018

Great. is created.

I don’t know how to force them to be “cpu multirace on windows”.   If you could do that sometime it’d be great.  No rush.  Thank you!


From: Phyx <lonetiger at>
Sent: 26 June 2018 06:01
To: Simon Peyton Jones <simonpj at>
Subject: Re: Strace

Hi Simon,

Thanks for the log, that does give a clue. The command fails with

setup.exe: 'C:/code/HEAD/inplace/bin/ghc-pkg.exe' exited with an error:
rule-defining-plugin-0.1: cannot find any of
on library path (use --force to override)

make[2]: *** [Makefile:18: package.T10420] Error 1

so it's the `setup install` from<> failing.

unfortunately, all those tests run with -v0 which is annoying because now the verbosity of the testsuite doesn't control that of these tests. I'm not sure why these commands fail under heavy load though.
I'll need to dive into the source of ghc-pkg to figure out what's happening. Notice that all the framework failures are these plugin tests which modify a package database. A wild guess is that ghc-pkg tries
to take a lock on all package-databases or something when it's mutating one. But I'm not intimately familiar with the package store and this doesn't explain why it doesn't happen on Linux.

for now one solution I can propose is to create a ticket to track these and mark these tests as cpu multirace on Windows, which will force them to run sequentially. I'll try to take a look at ghc-pkg this week
and if I don't figure anything out I'll force the tests sequential on the short term.


On Mon, Jun 25, 2018 at 4:08 AM, Simon Peyton Jones <simonpj at<mailto:simonpj at>> wrote:
I tried this
TEST_VERBOSITY="VERBOSE=3" sh validate --fast --no-clean >& log
in the root directory.  I get the framework failures, but I’m not sure the verbosity-control worked.
Log attached

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ghc-devs mailing list