Msys2 64: progress

Simon Peyton Jones simonpj at
Tue Jun 28 21:13:28 UTC 2016

Actually I had the command right; copy/paste somehow removed the underscore.
And curl –version does report
curl --version
curl 7.49.1 (x86_64-pc-msys)
so it should not be necessary anyway.

But ./configure still fails with
checking for path to top of build tree... C:/code/HEAD
configure: Checking for Windows toolchain tarballs...
configure: Extracting Windows toolchain from archives (may take a while)...
File not found - *.tar.xz

mk/ download x86_64
completes after 1 second, with no messages of any kind.

What next?!



From: ghc-devs [mailto:ghc-devs-bounces at] On Behalf Of lonetiger at
Sent: 28 June 2016 22:19
To: Simon Peyton Jones via ghc-devs <ghc-devs at>; David Macek <david.macek.0 at>; tamar at
Cc: ghc-devs at
Subject: RE: Msys2 64: progress

Hi Simon,

You’re missing an underscore in the command (there’s one between x86 and 64),

It’s pacman -R mingw-w64-x86_64-curl<>

This is only needed if curl --version reports anything other than x86_64-pc-msys.
After that you need to install the normal msys curl with pacman -S curl

You don’t have to run configure everytime to test either, you can just run

mk/ download x86_64

from the root and it should just download the packages only if everything is setup correctly.

Also don’t forget to do a pacman -Sy to update the repositories. Couldn’t gather from your email if you did this already.

Kind Regards,

From: Simon Peyton Jones via ghc-devs<mailto:ghc-devs at>
Sent: Tuesday, June 28, 2016 21:02
To: David Macek<mailto:david.macek.0 at>; tamar at<mailto:tamar at>
Cc: ghc-devs at<mailto:ghc-devs at>
Subject: Msys2 64: progress

I want to thank everyone who has responded – very helpful!
Thanks to your help I am making progress

·        I re-installed msys64 from scratch, this time following the instructions on the GHC wiki rather than the msys2 page.  By doing update-core; then pacman -Su; then pacman -Su again, I got a clean install.   Very good!

Getting a shell between each step is tricky.

o   The first shell is gotten with mingw64.bat

o   After update-core, that file is gone; you have to use msys2_shell.cmd I think

o   After pacman -Su we get mingw64.exe, which we can use thereafter.

·        My slow-start problem appears to have gone away.   I adopted the fix from

you may be hitting a long standing issue some computers have in which the domain controller is being hit for every invocation of commands, causing a slowdown , Solution 2 from<> seems to fix it for most people.

I am not absolutely certain that was the problem, but things seem ok now.  I also excluded c:/msys64 from my antivirus check.

·        Emacs too is now working normally.  Hurrah
So that’s all good.
Now I’m stuck on the windows tarballs download thing.  I get

configure: Checking for Windows toolchain tarballs...

configure: Extracting Windows toolchain from archives (may take a while)...

File not found - *.tar.xz
I tried both the things described on the wiki<>:

Pacman -R mingw-w64-x86_64-curl

error: target not found: mingw-w64-x86_64-curl
For the other I did the two mkdir things, and tried ./configure again, but got the same error message as above.
So I’m stuck again, but further forward.  Can you advise me?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ghc-devs mailing list