Msys2 64: progress

Simon Peyton Jones simonpj at
Tue Jun 28 20:02:11 UTC 2016

I want to thank everyone who has responded - very helpful!
Thanks to your help I am making progress

*        I re-installed msys64 from scratch, this time following the instructions on the GHC wiki rather than the msys2 page.  By doing update-core; then pacman -Su; then pacman -Su again, I got a clean install.   Very good!

Getting a shell between each step is tricky.

o   The first shell is gotten with mingw64.bat

o   After update-core, that file is gone; you have to use msys2_shell.cmd I think

o   After pacman -Su we get mingw64.exe, which we can use thereafter.

*        My slow-start problem appears to have gone away.   I adopted the fix from

you may be hitting a long standing issue some computers have in which the domain controller is being hit for every invocation of commands, causing a slowdown , Solution 2 from<> seems to fix it for most people.

I am not absolutely certain that was the problem, but things seem ok now.  I also excluded c:/msys64 from my antivirus check.

*        Emacs too is now working normally.  Hurrah
So that's all good.
Now I'm stuck on the windows tarballs download thing.  I get

configure: Checking for Windows toolchain tarballs...

configure: Extracting Windows toolchain from archives (may take a while)...

File not found - *.tar.xz
I tried both the things described on the wiki<>:

Pacman -R mingw-w64-x86_64-curl

error: target not found: mingw-w64-x86_64-curl
For the other I did the two mkdir things, and tried ./configure again, but got the same error message as above.
So I'm stuck again, but further forward.  Can you advise me?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ghc-devs mailing list