Why upper bound version numbers?
djsamperi at gmail.com
Mon Jun 6 21:02:12 UTC 2016
Why would a package developer want to upper bound the version number
for packages like base? For example, the clash package requires
base >= 4.2 && base <= 4.3
Consequently, it refuses to install with the latest ghc provided with
the Haskell Platform (8.0.1).
Does this mean that assuming that future versions of the platform will
remain backwards compatible with prior versions is unsafe?
More information about the ghc-devs