[ANNOUNCE] 7.10.3 release candidate 2

George Colpitts george.colpitts at gmail.com
Mon Nov 9 02:36:44 UTC 2015

I get

make[1]: *** [libraries/integer-gmp2/gmp/gmp.h] Error 1
make[1]: *** Waiting for unfinished jobs....
checking whether byte ordering is bigendian... no
checking assembler .cfi pseudo-op support... yes
checking for _ prefix in compiled symbols... yes
checking whether .eh_frame section should be read-only... expr: syntax error
checking for __attribute__((visibility("hidden")))... no
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating include/Makefile
config.status: creating include/ffi.h
config.status: creating Makefile
config.status: creating testsuite/Makefile
config.status: creating man/Makefile
config.status: creating libffi.pc
config.status: creating fficonfig.h
config.status: linking ../src/x86/ffitarget.h to include/ffitarget.h
config.status: executing buildir commands
config.status: create top_srcdir/Makefile guessed from local Makefile
config.status: build in x86_64-apple-darwin (HOST=)
config.status: executing depfiles commands
config.status: executing libtool commands
config.status: executing include commands
config.status: executing src commands
# wc on OS X has spaces in its output, which libffi's Makefile
# doesn't expect, so we tweak it to sed them out
mv libffi/build/Makefile libffi/build/Makefile.orig
sed "s#wc -w#wc -w | sed 's/ //g'#" < libffi/build/Makefile.orig >
"touch" libffi/stamp.ffi.static-shared.configure
make: *** [all] Error 2

Is that the same error you are getting?

On Sun, Nov 8, 2015 at 9:34 PM, Carter Schonwald <carter.schonwald at gmail.com
> wrote:

> I'm having trouble setting the make file flags to make the Mac build use
> the intree gmp.  I'm going to dig into this a bit more this evening.
> On Sunday, November 8, 2015, Ben Gamari <ben at well-typed.com> wrote:
>> Ben Gamari <ben at well-typed.com> writes:
>> > Ben Gamari <ben at well-typed.com> writes:
>> >
>> >> Hello everyone,
>> >>
>> >> We are pleased to announce the second release candidate for GHC 7.10.3:
>> >>
>> >>     https://downloads.haskell.org/~ghc/7.10.3-rc2/
>> >>
>> > It has been brought to my attention that the configure script in this
>> > source tarballs is out of date. Because of this `configure` will
>> > still fail on OS X. Reports suggest that there may be other issues
>> > unrelated to the configure issue on OS X as well.
>> >
>> Further testing suggests that perhaps the only issue is the out-of-date
>> `configure` script. Mac OS X users with `autotools` installed should be
>> able to run `./boot` in the source tree to bring `configure` up-to-date,
>> at which point this release candidate should be buildable.
>> I'll cut an -rc3 with a fixed `configure` script today.
>> Cheers,
>> - Ben
> _______________________________________________
> ghc-devs mailing list
> ghc-devs at haskell.org
> http://mail.haskell.org/cgi-bin/mailman/listinfo/ghc-devs
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.haskell.org/pipermail/ghc-devs/attachments/20151108/2b478c5c/attachment.html>

More information about the ghc-devs mailing list