tyConHash -- quick fix?

Simon Peyton Jones simonpj at microsoft.com
Wed Mar 11 09:39:41 UTC 2015


data TyCon = TyCon {

   tyConHash    :: {-# UNPACK #-} !Fingerprint, -- ^ @since 4.8.0.0

   tyConPackage :: String, -- ^ @since 4.5.0.0

   tyConModule  :: String, -- ^ @since 4.5.0.0

   tyConName    :: String  -- ^ @since 4.5.0.0

}

Friends,
Is tyConHash a good name here?  Wouldn't tyConFingerprint be better?

*         Hash functions usually yield a Int.

*         tyConFingerprint :: TyCon -> Fingerprint makes the name match the type.

*         If we had fingerprintHash:: Fingerprint -> Int, then we might want
tyConHash :: TyCon -> Int
tyConHash = fingerprintHash . tyConFingerpring

This is new in 7.10, so we could fix it now with no trouble.
Simon

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.haskell.org/pipermail/ghc-devs/attachments/20150311/c99df819/attachment.html>


More information about the ghc-devs mailing list