Re: build system question build-prog and bindisttest

Tamar Christina lonetiger at
Sun Jul 19 19:08:50 UTC 2015

Hi Thomas, 

Thanks for the help! 

I have removed the call to bindist and I was indeed missing a similar line in the main

Unfortunately I still get the same error:

  HC [stage 2] driver/ghc-split/dist/build/tmp/ghc-split.exe
/bin/sh: inplace/bin/ghc-stage2.exe: No such file or directory
driver/ghc-split/ recipe for target 'driver/ghc-split/dist/build/tmp/ghc-split.exe' failed
make[1]: *** [driver/ghc-split/dist/build/tmp/ghc-split.exe] Error 127

Though not quite sure why it’s looking in inplace/bin..  

I was indeed following that page, but haven't been able to consult the wiki today as Trac has been throwing an error all day. 

The line I added was:

driver/ghc-split/dist/ compiler/stage2/

Any ideas?



From: Thomas Miedema
Sent: ‎Sunday‎, ‎July‎ ‎19‎, ‎2015 ‎17‎:‎52
To: Tamar Christina

In my I have declared:

$(eval $(call build-prog,driver/ghc-split,dist,0))
$(eval $(call bindist,driver/ghc-split,

That second line isn't needed. I think you are trying to follow, but that information is outdated. Take a look at some files in the utils directory, for example `utils/hpc/`.

Now it's perfectly fine to build this at stage 1 or 2

Use stage1 to build it, or stage2 if you need access to the ghc api.

, but when I change it to either of those building fails telling me that
ghc-stage1 or ghc-stage2 cannot be found...

You are probably missing an entry like the following in the toplevel

utils/hpc/dist-install/ compiler/stage2/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ghc-devs mailing list