Installing ghc-7.10.2 linux binary distro on SuSE

Levent Erkok erkokl at
Mon Aug 31 16:00:41 UTC 2015

Tuncer: The LD_PRELOAD trick and the patchelf magic solved the problem

I'd still prefer if a SuSE binary distro was available from the downloads
page, for the good of the community. When I tried to build from source, I
was getting all sorts of error messages even from the configure step; so I
gave up fairly quickly. If it was a machine I had root access to then I'd
have given it more time; but with only user-level access, I didn't pursue
anything further.

On Sun, Aug 30, 2015 at 2:49 AM, Tuncer Ayaz <tuncer.ayaz at> wrote:

> On Sat, Aug 29, 2015 at 10:41 PM, Levent Erkok wrote:
> > Hello all,
> [...]
> > (Yes, I tried building from the source; but in the corporate
> > environment with so many things controlled, that did not go very
> > far.)
> What exactly failed? Have you tried using a same-distro-version SuSE
> chroot/container, where you install the SuSE-packaged GHC, for
> building 7.10.2? This is of course assuming that the autoconf check
> works.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ghc-devs mailing list